import re
regex = re.compile(r"(\d{3,4}\s*)?\D{2}(\s*\d{3,4})?", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("AD0200\n"
"PQ 200\n"
"sk 0315\n"
"0300AD\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")