import re
regex = re.compile(r"^([^#\n]+)", flags=re.MULTILINE)
test_str = ("### Description\n\n"
"This is a description\n\n"
"### Changelog\n\n"
"This is my changelog\n\n"
"### Automated Tests added\n\n"
"- Test 1\n"
"- Test 2\n\n"
"### Acceptance Tests performed\n\n\n\n"
"### Blurb\n\n"
"Concise summary of what this PR is.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")