re = /^([^#\n]+)/m
str = '### Description
This is a description
### Changelog
This is my changelog
### Automated Tests added
- Test 1
- Test 2
### Acceptance Tests performed
### Blurb
Concise summary of what this PR is.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end