const regex = /^i[A-za-z0-9]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^i[A-za-z0-9]+$', 'gm')
const str = `iGuKiscdvMrrSCaKGdmePT5ASu6gRJBHoB
iPokbyeGPuF46B27dAY3fRZAkKdDh8WbNr
iJhZPxQp7fWQCBvmyTFLAFs9Q8kWWEJHfi
iKs7Kv9gaLCoJVXvnPkqf4peXFqZrCG1G4
iJRXgmaiwQ5r6NnxDcFgT2yBpjtWB1y5vM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}