$re = '/^i[A-za-z0-9]+$/m';
$str = 'iGuKiscdvMrrSCaKGdmePT5ASu6gRJBHoB
iPokbyeGPuF46B27dAY3fRZAkKdDh8WbNr
iJhZPxQp7fWQCBvmyTFLAFs9Q8kWWEJHfi
iKs7Kv9gaLCoJVXvnPkqf4peXFqZrCG1G4
iJRXgmaiwQ5r6NnxDcFgT2yBpjtWB1y5vM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);