$re = '/\d+,\d+/';
$str = '84,96 <-- good
84.96 <-- bad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);