import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?<=^|.)returned to a\\.r\\.e\\. for (?=.*)";
final String string = "returned to A.R.E. for \n"
+ "Returned to A.R.E. for \n"
+ "RETURNED to A.R.E. for \n"
+ "RETURNED TO A.R.E. FOR \n"
+ "RETURNED to A.R.E. for A\n"
+ "A RETURNED to A.R.E. for \n"
+ "TEXTRETURNED to A.R.E. for TEXT\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}