re = /(?i)(?<=^|.)returned to a\.r\.e\. for (?=.*)/m
str = 'returned to A.R.E. for
Returned to A.R.E. for
RETURNED to A.R.E. for
RETURNED TO A.R.E. FOR
RETURNED to A.R.E. for A
A RETURNED to A.R.E. for
TEXTRETURNED to A.R.E. for TEXT
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end