$re = '/(\s*[#(])+$/m';
$str = 'that a nice ( #
that a nice (
that a ( nice ( #
that # a nice (#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);