re = /(\s*[#(])+$/m
str = 'that a nice ( #
that a nice (
that a ( nice ( #
that # a nice (#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end