const regex = /(?::\s*(?=:))?:[a-zA-Z0-9]+:/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?::\\s*(?=:))?:[a-zA-Z0-9]+:', 'gm')
const str = `: :1:1st message:2a:2nd message:x:this is where it fails status: fail :3:3rd message`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}