re = /(?::\s*(?=:))?:[a-zA-Z0-9]+:/m
str = ': :1:1st message:2a:2nd message:x:this is where it fails status: fail :3:3rd message'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end