import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+@\\w+(-\\w+)*(\\.\\w+(-\\w+)*)+$";
final String string = "foobar@-fear.com\n"
+ "foobar@fear-.com\n"
+ "foobar@fear.com-\n"
+ "foobar@fear.co--m\n"
+ "foobar@fea-r.com\n"
+ "foobar@fear.co-m";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}