$re = '/^\w+@\w+(-\w+)*(\.\w+(-\w+)*)+$/m';
$str = 'foobar@-fear.com
foobar@fear-.com
foobar@fear.com-
foobar@fear.co--m
foobar@fea-r.com
foobar@fear.co-m';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);