import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\p{L}{6}\\b";
final String string = "Ищу в куче абракадабры слово определенной длины, состоящее из букв и цифр. Я так понял нужно использовать регулярные выражения, гуглил гуглил но максимум что нагуглил было ^\\w{6,6}$, но результат не впечатлил, так как там после слов без пробела идут скобки и прочие спец символы, я так понял без пробела и результат поиска не будет верным, как мне быть";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}