// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)\b\p{L}{6}\b").unwrap();
let string = "Ищу в куче абракадабры слово определенной длины, состоящее из букв и цифр. Я так понял нужно использовать регулярные выражения, гуглил гуглил но максимум что нагуглил было ^\\w{6,6}$, но результат не впечатлил, так как там после слов без пробела идут скобки и прочие спец символы, я так понял без пробела и результат поиска не будет верным, как мне быть";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}