using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[^\W_]{6}\b";
string input = @"Ищу в куче абракадабры слово определенной длины, состоящее из букв и цифр. Я так понял нужно использовать регулярные выражения, гуглил гуглил но максимум что нагуглил было ^\w{6,6}$, но результат не впечатлил, так как там после слов без пробела идут скобки и прочие спец символы, я так понял без пробела и результат поиска не будет верным, как мне быть";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}