$re = '/\b[^\W_]{6}\b/u';
$str = 'Ищу в куче абракадабры слово определенной длины, состоящее из букв и цифр. Я так понял нужно использовать регулярные выражения, гуглил гуглил но максимум что нагуглил было ^\\w{6,6}$, но результат не впечатлил, так как там после слов без пробела идут скобки и прочие спец символы, я так понял без пробела и результат поиска не будет верным, как мне быть';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);