#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s*(?:(?:\S\s?)*\s+){2}(?:L\d+:\s*)?| +(?= )"
Local $sString = "1FC8 0801 000A BTst.B #$A, D1" & @CRLF & _
"1FCC 6608 BNE.B L315" & @CRLF & _
"1FCE 0240 00FF And #$FF, D0" & @CRLF & _
"1FD2 43F8 0400 Lea.L (DispatchTab), A1" & @CRLF & _
"1FD6 E548 L315: LsL #$2, D0" & @CRLF & _
"1FD8 2388 0000 Move.L A0, $0(A1,D0.W)" & @CRLF & _
"1FDC 7000 MoveQ.L #$0, D0" & @CRLF & _
"1FDE 4E75 Rts" & @CRLF & _
"1FE0 6102 L316: Bsr.B P42" & @CRLF & _
"1FE2 60F2 Bra.B L315" & @CRLF & _
"" & @CRLF & _
" P42:" & @CRLF & _
"1FE4 0240 01FF And #$1FF, D0" & @CRLF & _
"1FE8 43F8 0C00 Lea.L (ToolDispTable), A1" & @CRLF & _
"1FEC 0C40 0057 Cmp #$57, D0" & @CRLF & _
"1FF0 6212 BHI.B L318" & @CRLF & _
"1FF2 670C BEQ.B L317" & @CRLF & _
"1FF4 0C40 004F Cmp #$4F, D0" & @CRLF & _
"1FF8 6306 BLS.B L317" & @CRLF & _
"1FFA 0C40 0054 Cmp #$54, D0" & @CRLF & _
"1FFE 6604 BNE.B L318" & @CRLF & _
"2000 43F8 0400 L317: Lea.L (DispatchTab), A1" & @CRLF & _
"2004 4E75 L318: Rts" & @CRLF & _
"2006 61DC L319: Bsr.B P42" & @CRLF & _
"2008 601C Bra.B L320" & @CRLF & _
"" & @CRLF & _
" P_tGetTrapAddress:" & @CRLF & _
"200A 0801 0009 BTst.B #$9, D1" & @CRLF & _
"200E 67F6 BEQ.B L319" & @CRLF & _
"2010 0240 01FF And #$1FF, D0" & @CRLF & _
"2014 43F8 0C00 Lea.L (ToolDispTable), A1" & @CRLF & _
"2018 0801 000A BTst.B #$A, D1" & @CRLF & _
"201C 6608 BNE.B L320" & @CRLF & _
"201E 0240 00FF And #$FF, D0" & @CRLF & _
"2022 43F8 0400 Lea.L (DispatchTab), A1" & @CRLF & _
"2026 E548 L320: LsL #$2, D0" & @CRLF & _
"2028 2071 0000 Move.L $0(A1,D0.W), A0" & @CRLF & _
"202C 7000 MoveQ.L #$0, D0" & @CRLF & _
"202E 4E75 Rts"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)