package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.$`)
var str = ` Name
0 Tom hola.
1 secondx //
2 nick
3 krish here .`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}