$re = '/\.$/m';
$str = ' Name
0 Tom hola.
1 secondx //
2 nick
3 krish here .';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);