$re = '/(?<=[aeiou]|[a-zA-Z]\')/m';
$str = 'maxtin\'asiiro
luis\'suarez
marco\'polo
one two three';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);