re = /(?<=[aeiou]|[a-zA-Z]')/m
str = 'maxtin\'asiiro
luis\'suarez
marco\'polo
one two three'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end