#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)B(?=.{8,11}$)|B(?=.{0,3}$)"
Local $sString = "AAAABBBBAAAA" & @CRLF & _
"ABAABBBBAAAA" & @CRLF & _
"AAAABBBBABAA" & @CRLF & _
"BAAABBBBAAAB"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")