# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*(?:посёлок городского типа|село)\s(\w+).*/\1/gum;t' <<< "Россия, Республика , городской округ, посёлок городского типа Кяхулай, проезд Васильевский, 10
Россия, Республика , городской округ, село Кяхулай
городской округ Киров, село Кяхулай"