re = /.*(?:посёлок городского типа|село)\s(\w+).*/m
str = 'Россия, Республика , городской округ, посёлок городского типа Кяхулай, проезд Васильевский, 10
Россия, Республика , городской округ, село Кяхулай
городской округ Киров, село Кяхулай'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result