package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^a-zA-Z0-9$%&*+\/\-]`)
var str = `WZ 123456--12.123.45678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}