$re = '/[^a-zA-Z0-9$%&*+\/\-]/m';
$str = 'WZ 123456--12.123.45678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);