$re = '/\$(?:{([_a-zA-Z0-9]+)}|([_a-zA-Z0-9]+))\b/m';
$str = '$verb = verb
${verb}age = verb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);