package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\?.*`)
var str = `https://www.hotmovies.com/5006872/lesbian-daughter-in-laws-7-porn-video.html?studio=girlfriends-films`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}