re = /(^\d\s*|^\()/m
str = '1 555-555-5555
1 (555) 555-5555
5555555555
555-555-5555
(555)555-5555
1(555)555-5555
1 555 555 5555
1 456 789 4444'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end