$re = '/^[5][0-9]{8}$/';
$str = '523654789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);