package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:ab?c?d?)+$`)
var str = `a
abc
ab
babcd
aaaa
baa
the`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}