$re = '/^(?:ab?c?d?)+$/m';
$str = 'a
abc
ab
babcd
aaaa
baa
the';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);