# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^_?[a-z0-9]+(?:[._+-][a-z0-9]+)*@(?!\d+(?:\.\d+)*$)(?:\w+(?:-\w+)*\.)+\w{2,}$"
test_str = ("###################### Valid Emails ########################################################\n"
"######################## German, Austrian, international ###################################\n\n"
"janedoe@web.de\n"
"jane.doe@web.de\n"
"jdoe@web.de\n"
"jane-doe@web.de\n"
"jane@web.de\n"
"doe@web.de\n"
"janed@web.de\n"
"doej@web.de\n"
"jane_doe@web.de\n"
"j.doe@web.de\n"
"jane.d@web.de\n\n"
"janedoe@t-online.de\n"
"jane.doe@t-online.de\n"
"jdoe@t-online.de\n"
"jane-doe@t-online.de\n"
"jane@t-online.de\n"
"janed@t-online.de\n"
"doej@t-online.de\n"
"jane_doe@t-online.de\n"
"j.doe@t-online.de\n"
"jane.d@t-online.de\n\n"
"janedoe@hotmail.de\n"
"jane.doe@hotmail.de\n"
"jdoe@hotmail.de\n"
"jane-doe@hotmail.de\n\n"
"janedoe@gmx.de\n"
"jane.doe@gmx.de\n"
"jdoe@gmx.de\n"
"jane-doe@gmx.de\n\n\n"
"jane.doe@post.at\n"
"jane-doe@post.at\n"
"janedoe@post.at\n"
"jane@post.at\n"
"john.doe@austrian.com\n"
"horneaudrey@fulbright.at\n"
"email@example.web\n\n"
"#####################################################################################\n"
"########################## Not valid email ##########################################\n"
".test@gmail.com\n"
"-test@gmail.com\n"
"t.-.est@gmail.com\n"
".test.@gmail.com\n"
"test.@gmail.com\n"
"test.@.gmail.com\n"
"test@.gmail.com\n"
"test@.gmail.com.\n"
"test@gmail.com.\n\n"
"\"email\"@example.com\n\n"
"#@%^%#$@#$@#.com\n"
"@example.com\n"
"Joe Smith <email@example.com>\n"
"email.example.com\n"
"email@example@example.com\n"
".email@example.com\n"
"email.@example.com\n"
"email..email@example.com\n"
"あいうえお@example.com\n"
"email@example.com (Joe Smith)\n"
"email@example\n"
"email@-example.com\n"
"email@111.222.333.44444\n"
"email@example..com\n"
"Abc..123@example.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.