import Foundation
let pattern = #"^_?[a-z0-9]+(?:[._+-][a-z0-9]+)*@(?!\d+(?:\.\d+)*$)(?:\w+(?:-\w+)*\.)+\w{2,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ######################################################################################"""
###################### Valid Emails ########################################################
######################## German, Austrian, international ###################################
janedoe@web.de
jane.doe@web.de
jdoe@web.de
jane-doe@web.de
jane@web.de
doe@web.de
janed@web.de
doej@web.de
jane_doe@web.de
j.doe@web.de
jane.d@web.de
janedoe@t-online.de
jane.doe@t-online.de
jdoe@t-online.de
jane-doe@t-online.de
jane@t-online.de
janed@t-online.de
doej@t-online.de
jane_doe@t-online.de
j.doe@t-online.de
jane.d@t-online.de
janedoe@hotmail.de
jane.doe@hotmail.de
jdoe@hotmail.de
jane-doe@hotmail.de
janedoe@gmx.de
jane.doe@gmx.de
jdoe@gmx.de
jane-doe@gmx.de
jane.doe@post.at
jane-doe@post.at
janedoe@post.at
jane@post.at
john.doe@austrian.com
horneaudrey@fulbright.at
email@example.web
#####################################################################################
########################## Not valid email ##########################################
.test@gmail.com
-test@gmail.com
t.-.est@gmail.com
.test.@gmail.com
test.@gmail.com
test.@.gmail.com
test@.gmail.com
test@.gmail.com.
test@gmail.com.
"email"@example.com
#@%^%#$@#$@#.com
@example.com
Joe Smith <email@example.com>
email.example.com
email@example@example.com
.email@example.com
email.@example.com
email..email@example.com
あいうえお@example.com
email@example.com (Joe Smith)
email@example
email@-example.com
email@111.222.333.44444
email@example..com
Abc..123@example.com
"""######################################################################################
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)