package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(?:da|de|do|dos|das)\s+)?\S+`)
var str = `Francisco da Sousa Rodrigues
Emiliano Rodrigo Carrasco
Alberto de Francia
Bruno Rezende`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}