$re = '/(?:(?:da|de|do|dos|das)\s+)?\S+/m';
$str = 'Francisco da Sousa Rodrigues
Emiliano Rodrigo Carrasco
Alberto de Francia
Bruno Rezende';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);