package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?i)(0?[1-9]|1[0-9]|2[0-4]):([0-5][0-9])(:[0-5][0-9])?( AM| PM)?$`)
var str = `8:10 am
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}