re = /^(?i)(0?[1-9]|1[0-9]|2[0-4]):([0-5][0-9])(:[0-5][0-9])?( AM| PM)?$/m
str = '8:10 am
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end