$re = '/@due(\((?>[^()\/]|(?1))*+\))/';
$str = 'aaa @tag @due(test(a(a)))() bbb @high @beephigh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);