#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=:[^:$\n]*)\$\w+(?:-\w+)*"
Local $sString = ".dabur-india{" & @CRLF & _
" color: $color-brand-group-3-light !important;" & @CRLF & _
" .mmm{" & @CRLF & _
" background: $color-brand-group-2-dark;" & @CRLF & _
" $border-dark: rgba($base-color, 0.88);" & @CRLF & _
" .alert {" & @CRLF & _
" border: 1px solid $border-dark;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"$black: #000 !default;" & @CRLF & _
"$border-radius: 0.25rem !default;" & @CRLF & _
"$box-shadow: 0 0.5rem 1rem rgba($black, 0.15) !default;" & @CRLF & _
"" & @CRLF & _
"code {" & @CRLF & _
" border-radius: $border-radius;" & @CRLF & _
" box-shadow: $box-shadow;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"@if $dark-theme {" & @CRLF & _
" $primary-color: darken($primary-color, 60%);" & @CRLF & _
" $accent-color: lighten($accent-color, 60%);" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"$theme-colors: (" & @CRLF & _
" "success": #28a745," & @CRLF & _
" "info": #17a2b8," & @CRLF & _
" "warning": #ffc107," & @CRLF & _
");" & @CRLF & _
"" & @CRLF & _
".alert {" & @CRLF & _
" // Instead of $theme-color-#{warning}" & @CRLF & _
" background-color: map.get($theme-colors, "warning");" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")