$re = '/\b[a-z]+_[a-z]+_[a-z]+_[a-z]+\b/m';
$str = 'xxx_yyyyyy_zzz_aaaaa
xxx_yyyyyy_zzz_aaaaa_cat
xxx_yyyyyy_zzz_aaaaa_uom';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);