// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[a-z]+_[a-z]+_[a-z]+_[a-z]+\b").unwrap();
let string = "xxx_yyyyyy_zzz_aaaaa
xxx_yyyyyy_zzz_aaaaa_cat
xxx_yyyyyy_zzz_aaaaa_uom";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}