import re
regex = re.compile(r"^(import)(?:.*?(as))?(?:.*?(as))?(?:.*?(from))*.*$", flags=re.MULTILINE)
test_str = ("import \"./test\"\n"
"import \"./test\" as Test\n"
"import { Test } from \"./test\"\n"
"import { Person as Individual } from \"./test\"\n"
"import { Person as Individual, Test, Bag as Backpack } from \"./test\"\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")