#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(\w*):\s+(.+)\((\d+)\)(.+)\s+--\s+(.+)$"
Local $sString = "ERROR: design_fixed/mdct/DBUFCTL.VHD(38)entity_017 -- Move : -1 columns" & @CRLF & _
"ERROR: design_fixed/mdct/DBUFCTL.VHD(59)process_035 -- Move 13 columns" & @CRLF & _
"ERROR: design_fixed/mdct/DCT2D.VHD(329)instantiation_033 -- Add *component* keyword" & @CRLF & _
"ERROR: design_fixed/mdct/MDCT.VHD(83)instantiation_034 -- Change to component instantiation" & @CRLF & _
"ERROR: design_fixed/mdct/RAM.VHD(36)entity_017 -- Move : -12 columns"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")