# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\w*):\s+(.+)\((\d+)\)(.+)\s+--\s+(.+)$"
test_str = ("ERROR: design_fixed/mdct/DBUFCTL.VHD(38)entity_017 -- Move : -1 columns\n"
"ERROR: design_fixed/mdct/DBUFCTL.VHD(59)process_035 -- Move 13 columns\n"
"ERROR: design_fixed/mdct/DCT2D.VHD(329)instantiation_033 -- Add *component* keyword\n"
"ERROR: design_fixed/mdct/MDCT.VHD(83)instantiation_034 -- Change to component instantiation\n"
"ERROR: design_fixed/mdct/RAM.VHD(36)entity_017 -- Move : -12 columns")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.