#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\s+_[A-Za-z]+\._)"
Local $sString = "was from an authentic copy, and a careful comparison of the text with" & @CRLF & _
"the earlier one shows that in the meantime the play "underwent revision," & @CRLF & _
"received some slight augmentation, and in some few places must have been" & @CRLF & _
"entirely rewritten." A marked instance of this rewriting--the only one" & @CRLF & _
"of considerable length--is in ii. 6. 6-37, where the first quarto reads" & @CRLF & _
"thus (spelling and pointing being modernized):--" & @CRLF & _
"" & @CRLF & _
" _Jul._ Romeo." & @CRLF & _
"" & @CRLF & _
" _Rom._ My Juliet, welcome. As do waking eyes" & @CRLF & _
" Closed in Night's mists attend the frolick Day," & @CRLF & _
" So Romeo hath expected Juliet," & @CRLF & _
" And thou art come." & @CRLF & _
"" & @CRLF & _
" _Jul._ I am, if I be Day," & @CRLF & _
" Come to my Sun: shine forth and make me fair." & @CRLF & _
"" & @CRLF & _
" _Rom._ All beauteous fairness dwelleth in thine eyes." & @CRLF & _
"" & @CRLF & _
" _Jul._ Romeo, from thine all brightness doth arise." & @CRLF & _
"" & @CRLF & _
" _Fri._ Come, wantons, come, the stealing hours do pass," & @CRLF & _
" Defer embracements till some fitter time." & @CRLF & _
" Part for a while, you shall not be alone" & @CRLF & _
" Till holy Church have joined ye both in one." & @CRLF & _
"" & @CRLF & _
" _Rom._ Lead, holy Father, all delay seems long." & @CRLF & _
"" & @CRLF & _
" _Jul._ Make haste, make haste, this lingering doth us wrong." & @CRLF & _
"" & @CRLF & _
"For convenient comparison I quote the later text here:--" & @CRLF & _
"" & @CRLF & _
" _Juliet._ Good even to my ghostly confessor." & @CRLF & _
"" & @CRLF & _
" _Friar Laurence._ Romeo shall thank thee, daughter, for us both." & @CRLF & _
"" & @CRLF & _
" _Juliet._ As much to him, else is his thanks too much." & @CRLF & _
"" & @CRLF & _
" _Romeo._ Ah, Juliet, if the measure of thy joy" & @CRLF & _
" Be heap'd like mine and that thy skill be more" & @CRLF & _
" To blazon it, then sweeten with thy breath" & @CRLF & _
" This neighbour air, and let rich music's tongue" & @CRLF & _
" Unfold the imagin'd happiness that both" & @CRLF & _
" Receive in either by this dear encounter." & @CRLF & _
"" & @CRLF & _
" _Juliet._ Conceit, more rich in matter than in words," & @CRLF & _
" Brags of his substance, not of ornament." & @CRLF & _
" They are but beggars that can count their worth;" & @CRLF & _
" But my true love is grown to such excess" & @CRLF & _
" I cannot sum up half my sum of wealth." & @CRLF & _
"" & @CRLF & _
" _Friar Laurence._ Come, come with me, and we will make short work;" & @CRLF & _
" For, by your leaves, you shall not stay alone" & @CRLF & _
" Till holy church incorporate two in one." & @CRLF & _
"" & @CRLF & _
"The "omission, mutilation, or botching" by which some German editors" & @CRLF & _
"would explain all differences between the earlier and later texts will" & @CRLF & _
"not suffice to account for such divergence as this. "The two dialogues" & @CRLF & _
"do not differ merely in expressiveness and effect; they embody different" & @CRLF & _
"conceptions of the characters;" and yet we cannot doubt that both were" & @CRLF & _
"written by Shakespeare." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")