package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(?:to|of|at)\b`)
var str = `Legend Of Zelda`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}