$re = '/\b(?:to|of|at)\b/iu';
$str = 'Legend Of Zelda';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);